Anyone else having issues with the Point Hacks Nab Signature Qantas Visa application?

Ive been trying several times a day, for a week to apply for this card on line through points hack and all I get is system unavailable! Is anyone getting through?

I just got through without a hitch. The link worked on Chrome and Edge browsers.

Guess you are lucky. I can’t get through with IE, Firefox, Mozilla or Edge and have now given up

I believed that I had successfully applied through the Point Hacks site, but have since been told by NAB that I am not eliable for the Point Hacks bonus. Their response was:

“The website you’ve provide isn’t associated with NAB. You can follow this up with Point Hack to see how the card was opened.”

Very disappointing.

Yes I’m not too sure what this is all about. NAB don’t want to honour the bonus points and Points Hack seem strangely silent. Are their offers not to be trusted ? Now 2 weeks and still can’t get through. Supposed offer end 17 June but  whats the point?

Hey pegasussyd and morganmcintosh (and anyone else having issues with the offer) - sorry to hear about this, and for taking a while to respond to your comments/question.

We will reach out to you both by email to try and assist with troubleshooting this further (if you would like to continue with the process), so look out for that email. Anyone else having issues can also do the same by emailing us at

We are having a couple of issues which we are working with NAB to resolve - the first is technical, where the form is causing issues during the application process, and the second is around is customer service knowing about and supporting this offer. I thought these were under control, but clearly there are still problems.

Many people have applied successfully and it’s proving difficult to get these issues resolved for people who are having problems, especially the technical one where we can’t find out why some applicants are getting blocked.

Sorry for the hassle - I hate it when offers don’t go right for everyone and we’ll do what we can to help.

As of 8th June, tried Firefox, Chrome and Edge nil working. Pretty poor, can’t even get the NAB website to open an application so I suspect  they don’t want any more applications.

Just disabled my Kapersky Interent Security and link opened to application, but not ideal when providing all personal details.