Having problems booking AAdvantage flights with seats showing but not bookable

Hi there, I’ve noticed a problem tyring to redeem points on AAdvantage. The flights show up as available to book. I select the flights and then on the next screen ‘The flight you select is no longer available’  comes up. Modified my request, tried various different dates over 10 months and still the same. I’ve sent a message to AA but just wondered if anyone else was experiencing this problem.

What you are experiencing is called “phantom seats”. Ie. These seats are not really there, or they were taken already and AA’s search engine just hasn’t keep up with the updates.

Its best to confirm those seats are actually available in other OW search engine such as Qantas or British Airways. The most accurate one is JAL. If JAL says it’s there, then it’s definitely there (although if it’s not in JAL’s it might still be there…).

If you confirmed with those other search engines and confirmed the seats are definitely there, then give AA a call and see if they can book it for you manually, and ask them to waive phone booking fee cuz you can’t book online.

I’m no sure what’s going on at AA but availability on the kangaroo route seems to have been gutted…